PT-2015-6845
CVE-2015-5309
·
تاريخ النشر
2015-11-10
·
تاريخ التحديث
2024-06-15
الوصف من
CVSS 2.0
4.3
متوسطةالمقاييسAV:N/AC:M/Au:N/C:N/I:N/A:P
Name of the Vulnerable Software and Affected Versions
PuTTY versions prior to 0.66
Description
The issue is related to an integer overflow in the terminal emulator, which can be triggered by a remote attacker using an ECH (erase characters) escape sequence with a large parameter value. This can cause a denial of service due to memory corruption or potentially allow the execution of arbitrary code.
Recommendations
For versions prior to 0.66, update to version 0.66 or later to resolve the issue. As a temporary workaround, consider restricting access to the terminal emulator until the update is applied.
وجدت خطأً في الوصف؟ لديك ما تضيفه؟ لا تتردد في مراسلتنا 👾