PT-2016-1431

CVE-2016-2570

·

تاريخ النشر

2014-04-24

·

تاريخ التحديث

2018-03-16

الوصف من

CVSS 3.1
7.5
عالية
المقاييسAV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Name of the Vulnerable Software and Affected Versions Squid versions 3.x through 3.5.14 Squid versions 4.x through 4.0.6
Description The issue is related to the Edge Side Includes (ESI) parser in Squid, which does not properly check buffer limits during XML parsing. This allows remote HTTP servers to cause a denial of service, resulting in an assertion failure and daemon exit, by sending a crafted XML document. The problem is associated with the files esi/CustomParser.cc and esi/CustomParser.h.
Recommendations For Squid versions 3.x through 3.5.14, update to version 3.5.15 or later. For Squid versions 4.x through 4.0.6, update to version 4.0.7 or later.
قابلية الاستغلال
استغلال
إصلاح
التأثيرات
الباحثون
المورّدون
المنتجات المتأثرة
تصنيف نقاط الضعف
المعرّفات ذات الصلة
ALT-PU-2014-1531
ALT-PU-2015-1383
CESA-2016_2600
MGASA-2016-0095
RHSA-2016:2600
RHSA-2016_2600
SUSE-SU-2016:2008-1
SUSE-SU-2016:2089-1
USN-3557-1
وجدت خطأً في الوصف؟ لديك ما تضيفه؟ لا تتردد في مراسلتنا 👾