PT-2016-1514

CVE-2015-7576

·

تاريخ النشر

2016-01-31

·

تاريخ التحديث

2019-08-08

الوصف من

CVSS 2.0
4.3
متوسطة
المقاييسAV:N/AC:M/Au:N/C:P/I:N/A:N
Name of the Vulnerable Software and Affected Versions Ruby on Rails versions prior to 3.2.22.1 Ruby on Rails versions 4.0.x through 4.1.14 Ruby on Rails versions 4.2.x through 4.2.5 Ruby on Rails versions 5.x through 5.0.0.beta1
Description The issue is related to the http basic authenticate with method in the Basic Authentication implementation in Action Controller, which does not use a constant-time algorithm for verifying credentials. This makes it easier for remote attackers to bypass authentication by measuring timing differences. The vulnerability can be exploited by a remote attacker to bypass the authentication procedure.
Recommendations For Ruby on Rails versions prior to 3.2.22.1, update to version 3.2.22.1 or later. For Ruby on Rails versions 4.0.x through 4.1.14, update to version 4.1.14.1 or later. For Ruby on Rails versions 4.2.x through 4.2.5, update to version 4.2.5.1 or later. For Ruby on Rails versions 5.x through 5.0.0.beta1, update to version 5.0.0.beta1.1 or later.
قابلية الاستغلال
استغلال
إصلاح
الباحثون
المورّدون
المنتجات المتأثرة
تصنيف نقاط الضعف
المعرّفات ذات الصلة
GHSA-P692-7MM3-3FXG
GHSA-VWFG-QJ3R-6V3R
DLA-604-1
DSA-3464-1
RHSA-2016:0296
RHSA-2016:0454
RHSA-2016:0455
SUSE-SU-2016:0435-1
SUSE-SU-2016:0457-1
SUSE-SU-2016:0600-1
SUSE-SU-2016:0618-1
SUSE-SU-2016:0623-1
SUSE-SU-2016_0623-1
SUSE-SU-2016:0857-1
SUSE-SU-2016:0858-1
SUSE-SU-2016:0968-1
SUSE-SU-2016_0968-1
SUSE-SU-2016:1146-1
SUSE-SU-2017:0475-1
وجدت خطأً في الوصف؟ لديك ما تضيفه؟ لا تتردد في مراسلتنا 👾