PT-2016-1607

CVE-2016-3142

·

تاريخ النشر

2016-03-31

·

تاريخ التحديث

2018-01-05

الوصف من

CVSS 3.1
8.2
عالية
المقاييسAV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:H
Name of the Vulnerable Software and Affected Versions PHP versions prior to 5.5.33 PHP versions 5.6.x prior to 5.6.19
Description The issue is caused by a buffer overflow in the phar parse zipfile function of the PHAR extension in PHP. This can be exploited by a remote attacker to obtain sensitive information from process memory or cause a denial of service, resulting in an out-of-bounds read and application crash. The exploitation involves placing a PKx05x06 signature at an invalid location.
Recommendations For PHP versions prior to 5.5.33, update to version 5.5.33 or later. For PHP versions 5.6.x prior to 5.6.19, update to version 5.6.19 or later. As a temporary workaround, consider restricting the use of the PHAR extension until a patch is available.
قابلية الاستغلال
استغلال
إصلاح
التأثيرات
المورّدون
المنتجات المتأثرة
المعرّفات ذات الصلة
DLA-818-1
OPENSUSE-SU-2016_1167-1
OPENSUSE-SU-2016_1173-1
RHSA-2016:2750
SUSE-SU-2016:1145-1
SUSE-SU-2016:1166-1
SUSE-SU-2016:1581-1
SUSE-SU-2016:1638-1
USN-2952-1
وجدت خطأً في الوصف؟ لديك ما تضيفه؟ لا تتردد في مراسلتنا 👾