PT-2016-2030
CVE-2016-1835
·
تاريخ النشر
2016-05-20
·
تاريخ التحديث
2024-06-15
الوصف من
CVSS 3.1
8.8
عاليةالمقاييسAV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Name of the Vulnerable Software and Affected Versions
libxml2 versions prior to 2.9.4
Apple iOS versions prior to 9.3.2
Apple OS X versions prior to 10.11.5
Description
The issue is caused by a buffer overflow in the libxml2 library, which can be exploited by a remote attacker using a specially crafted XML document. This can lead to arbitrary code execution or a denial of service (memory corruption). The vulnerability is also described as a use-after-free issue in the
xmlSAX2AttributeNs function, allowing remote attackers to cause a denial of service via a crafted XML document.Recommendations
For libxml2 versions prior to 2.9.4, update to version 2.9.4 or later to resolve the issue.
For Apple iOS versions prior to 9.3.2, update to version 9.3.2 or later to resolve the issue.
For Apple OS X versions prior to 10.11.5, update to version 10.11.5 or later to resolve the issue.
As a temporary workaround, consider restricting the use of the
xmlSAX2AttributeNs function until a patch is available. Avoid using specially crafted XML documents that could exploit the buffer overflow vulnerability. وجدت خطأً في الوصف؟ لديك ما تضيفه؟ لا تتردد في مراسلتنا 👾