PT-2016-2089

CVE-2016-4345

·

تاريخ النشر

2016-05-21

·

تاريخ التحديث

2022-07-20

الوصف من

CVSS 3.1
9.8
حرجة
المقاييسAV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Name of the Vulnerable Software and Affected Versions PHP versions prior to 7.0.4
Description The issue is related to an integer overflow in the php filter encode url function, which can cause a heap-based buffer overflow. This can lead to a denial of service or possibly have other unspecified impacts when a remote attacker sends a long string.
Recommendations For PHP versions prior to 7.0.4, update to version 7.0.4 or later to resolve the issue. As a temporary workaround, consider restricting the input length to the php filter encode url function to minimize the risk of exploitation.
قابلية الاستغلال
استغلال
إصلاح
التأثيرات
الباحثون
المورّدون
المنتجات المتأثرة
المعرّفات ذات الصلة
وجدت خطأً في الوصف؟ لديك ما تضيفه؟ لا تتردد في مراسلتنا 👾