PT-2016-3206

CVE-2016-4461

·

تاريخ النشر

2016-04-12

·

تاريخ التحديث

2022-05-14

الوصف من

CVSS 2.0
9.0
عالية
المقاييسAV:N/AC:L/Au:S/C:C/I:C/A:C
Name of the Vulnerable Software and Affected Versions Apache Struts versions 2.x through 2.3.28
Description The issue allows remote attackers to execute arbitrary code via a %{} sequence in a tag attribute, also known as forced double OGNL evaluation. This is due to insufficient input validation. The vulnerability can be exploited by a remote attacker to execute arbitrary code using the %{} sequence in a tag attribute.
Recommendations For Apache Struts versions 2.x through 2.3.28, update to version 2.3.29 or later to resolve the issue. As a temporary workaround, consider restricting the use of tag attributes that may contain the %{} sequence to minimize the risk of exploitation.
قابلية الاستغلال
إصلاح
التأثيرات
المورّدون
المنتجات المتأثرة
المعرّفات ذات الصلة
GHSA-864W-R5QJ-H6FJ
وجدت خطأً في الوصف؟ لديك ما تضيفه؟ لا تتردد في مراسلتنا 👾