PT-2016-3302
CVE-2016-9941
·
تاريخ النشر
2016-11-24
·
تاريخ التحديث
2020-10-23
الوصف من
CVSS 3.1
9.8
حرجةالمقاييسAV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Name of the Vulnerable Software and Affected Versions
LibVNCServer versions prior to 0.9.11
Description
The issue is related to a heap-based buffer overflow in the rfbproto.c component of LibVNCServer, which can be exploited by remote servers. This can lead to a denial of service, causing the application to crash, or possibly allow the execution of arbitrary code. The vulnerability is triggered by a crafted FramebufferUpdate message containing a subrectangle outside of the client drawing area.
Recommendations
For versions prior to 0.9.11, update to version 0.9.11 or later to resolve the issue. As a temporary workaround, consider restricting access to the
rfbproto.c component or limiting the handling of FramebufferUpdate messages to minimize the risk of exploitation. وجدت خطأً في الوصف؟ لديك ما تضيفه؟ لا تتردد في مراسلتنا 👾