PT-2016-3351

CVE-2016-20011

·

تاريخ النشر

2016-10-09

·

تاريخ التحديث

2021-10-25

الوصف من

CVSS 3.1
7.5
عالية
المقاييسAV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N
Name of the Vulnerable Software and Affected Versions libgrss versions prior to 0.7.1
Description The issue is related to the failure of libgrss to perform TLS certificate verification when downloading feeds. This is due to the default behavior of SoupSessionSync, allowing remote attackers to manipulate feed contents without detection. The vulnerability can be exploited by a remote attacker to impact data integrity.
Recommendations For libgrss versions prior to 0.7.1, update to version 0.7.1 or later to resolve the issue. As a temporary workaround, consider disabling the use of SoupSessionSync until a patch is available. Restrict access to feeds from untrusted sources to minimize the risk of exploitation.
قابلية الاستغلال
إصلاح
التأثيرات
الباحثون
المورّدون
المنتجات المتأثرة
تصنيف نقاط الضعف
المعرّفات ذات الصلة
وجدت خطأً في الوصف؟ لديك ما تضيفه؟ لا تتردد في مراسلتنا 👾