PT-2016-3384
CVE-2016-7132
·
تاريخ النشر
2016-09-11
·
تاريخ التحديث
2020-11-16
الوصف من
CVSS 2.0
7.8
عاليةالمقاييسAV:N/AC:L/Au:N/C:N/I:N/A:C
Name of the Vulnerable Software and Affected Versions
PHP versions prior to 5.6.25
PHP versions 7.x prior to 7.0.10
Description
The issue is related to errors in pointer dereferencing in the ext/wddx/wddx.c component of the PHP interpreter. It can be exploited by a remote attacker to cause a denial of service through an invalid XML document. The exploitation may involve a wddxPacket XML document that is mishandled in a
wddx deserialize call, potentially leading to a NULL pointer dereference and application crash.Recommendations
For PHP versions prior to 5.6.25, update to version 5.6.25 or later.
For PHP versions 7.x prior to 7.0.10, update to version 7.0.10 or later.
قابلية الاستغلال
استغلال
إصلاح
التأثيرات
الباحثون
المورّدون
المنتجات المتأثرة
وجدت خطأً في الوصف؟ لديك ما تضيفه؟ لا تتردد في مراسلتنا 👾