PT-2016-3404
CVE-2016-5769
·
تاريخ النشر
2016-06-24
·
تاريخ التحديث
2016-11-28
الوصف من
CVSS 3.1
10
حرجةالمقاييسAV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Name of the Vulnerable Software and Affected Versions
PHP versions prior to 5.5.37
PHP versions 5.6.x prior to 5.6.23
PHP versions 7.x prior to 7.0.8
Description
The issue is caused by multiple integer overflows in the mcrypt extension, which can be exploited by remote attackers to cause a denial of service, such as a heap-based buffer overflow and application crash, or possibly have other unspecified impacts. This is related to the
mcrypt generic and mdecrypt generic functions, and can be triggered through a crafted length value.Recommendations
For PHP versions prior to 5.5.37, update to version 5.5.37 or later.
For PHP versions 5.6.x prior to 5.6.23, update to version 5.6.23 or later.
For PHP versions 7.x prior to 7.0.8, update to version 7.0.8 or later.
وجدت خطأً في الوصف؟ لديك ما تضيفه؟ لا تتردد في مراسلتنا 👾