PT-2016-3807
CVE-2015-7546
·
تاريخ النشر
2016-02-03
·
تاريخ التحديث
2026-07-09
الوصف من
CVSS 4.0
8.6
عاليةالمقاييسAV:N/AC:L/AT:N/PR:L/UI:P/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N
Name of the Vulnerable Software and Affected Versions
OpenStack Identity (Keystone) versions prior to 2015.1.3
OpenStack Identity (Keystone) versions 8.0.x prior to 8.0.2
keystonemiddleware versions prior to 1.5.4
Liberty versions prior to 2.3.3
Description
The issue is related to the improper invalidation of authorization tokens when using the PKI or PKIZ token providers. This allows remote authenticated users to bypass intended access restrictions and gain access to cloud resources by manipulating byte fields within a revoked token.
Recommendations
For OpenStack Identity (Keystone) versions prior to 2015.1.3, update to version 2015.1.3 or later.
For OpenStack Identity (Keystone) versions 8.0.x prior to 8.0.2, update to version 8.0.2 or later.
For keystonemiddleware versions prior to 1.5.4, update to version 1.5.4 or later.
For Liberty versions prior to 2.3.3, update to version 2.3.3 or later.
وجدت خطأً في الوصف؟ لديك ما تضيفه؟ لا تتردد في مراسلتنا 👾