PT-2016-4017
CVE-2015-8779
·
تاريخ النشر
2016-02-16
·
تاريخ التحديث
2024-06-15
الوصف من
CVSS 3.1
9.8
حرجةالمقاييسAV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Name of the Vulnerable Software and Affected Versions
glibc versions prior to 2.23
Description
The issue is related to a stack-based buffer overflow in the catopen function, which can be exploited by context-dependent attackers. This can lead to a denial of service, causing the application to crash, or potentially allow the execution of arbitrary code if a long catalog name is used.
Recommendations
For versions prior to 2.23, update to version 2.23 or later to resolve the issue. As a temporary workaround, consider restricting the length of catalog names to prevent exploitation.
قابلية الاستغلال
استغلال
إصلاح
التأثيرات
الباحثون
المورّدون
المنتجات المتأثرة
وجدت خطأً في الوصف؟ لديك ما تضيفه؟ لا تتردد في مراسلتنا 👾