PT-2016-4026

CVE-2015-8796

·

تاريخ النشر

2016-02-15

·

تاريخ التحديث

2022-05-17

الوصف من

CVSS 3.1
6.1
متوسطة
المقاييسAV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
Name of the Vulnerable Software and Affected Versions Apache Solr versions prior to 5.3
Description A cross-site scripting (XSS) issue exists in the Admin UI, specifically in the webapp/web/js/scripts/schema-browser.js file, allowing remote attackers to inject arbitrary web script or HTML via a crafted schema-browse URL, such as "/schema-browser". This enables attackers to execute malicious scripts on the client-side.
Recommendations For versions prior to 5.3, update to version 5.3 or later to resolve the issue. As a temporary workaround, consider restricting access to the Admin UI to minimize the risk of exploitation. Avoid using crafted schema-browse URLs in the affected API endpoint until the issue is resolved.
قابلية الاستغلال
إصلاح
التأثيرات
المورّدون
المنتجات المتأثرة
المعرّفات ذات الصلة
GHSA-4FXW-G29W-R8MX
وجدت خطأً في الوصف؟ لديك ما تضيفه؟ لا تتردد في مراسلتنا 👾