PT-2016-5047

CVE-2016-2174

·

تاريخ النشر

2016-06-13

·

تاريخ التحديث

2018-10-17

الوصف من

CVSS 3.1
7.2
عالية
المقاييسAV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H
Name of the Vulnerable Software and Affected Versions Apache Ranger versions prior to 0.5.3
Description The issue allows remote authenticated administrators to execute arbitrary SQL commands. This is achieved by exploiting the eventTime parameter in the /service/plugins/policies/eventTime API endpoint.
Recommendations For versions prior to 0.5.3, update to version 0.5.3 or later to resolve the issue. As a temporary workaround, consider restricting access to the /service/plugins/policies/eventTime API endpoint to minimize the risk of exploitation. Avoid using the eventTime parameter in the affected API endpoint until the issue is resolved.
قابلية الاستغلال
إصلاح
التأثيرات
الباحثون
المورّدون
المنتجات المتأثرة
المعرّفات ذات الصلة
GHSA-4RJF-MXFM-98H5
وجدت خطأً في الوصف؟ لديك ما تضيفه؟ لا تتردد في مراسلتنا 👾