PT-2016-5193

CVE-2016-2537

·

تاريخ النشر

2016-02-23

·

تاريخ التحديث

2018-07-31

الوصف من

CVSS 3.1
7.5
عالية
المقاييسAV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Name of the Vulnerable Software and Affected Versions is-my-json-valid versions prior to 2.17.2 is-my-json-valid versions prior to 1.4.1
Description The issue is related to an incorrect regular expression in the is-my-json-valid package, which can cause a denial of service (blocked event loop) via a crafted string. This can be exploited by remote attackers. The vulnerability is also described as a regular expression denial of service (ReDoS) via the email validation function.
Recommendations Update to version 1.4.1 or later. Update to version 2.17.2 or later.
قابلية الاستغلال
إصلاح
التأثيرات
المورّدون
المنتجات المتأثرة
المعرّفات ذات الصلة
GHSA-CCQ6-3QX5-VMQX
GHSA-F522-FFG8-J8R6
وجدت خطأً في الوصف؟ لديك ما تضيفه؟ لا تتردد في مراسلتنا 👾