PT-2016-6024
CVE-2016-4564
·
تاريخ النشر
2016-03-30
·
تاريخ التحديث
2016-11-21
الوصف من
CVSS 3.1
9.8
حرجةالمقاييسAV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Name of the Vulnerable Software and Affected Versions
ImageMagick versions prior to 6.9.4-0
ImageMagick versions 7.x prior to 7.0.1-2
Description
The issue is related to the DrawImage function in MagickCore/draw.c, which makes an incorrect function call when attempting to locate the next token. This can be exploited by remote attackers using a crafted file, potentially causing a denial of service due to a buffer overflow and application crash, or possibly having other unspecified impacts.
Recommendations
For ImageMagick versions prior to 6.9.4-0, update to version 6.9.4-0 or later.
For ImageMagick versions 7.x prior to 7.0.1-2, update to version 7.0.1-2 or later.
وجدت خطأً في الوصف؟ لديك ما تضيفه؟ لا تتردد في مراسلتنا 👾