PT-2016-6399

CVE-2016-5385

·

تاريخ النشر

2016-07-18

·

تاريخ التحديث

2024-06-15

الوصف من

CVSS 3.1
8.1
عالية
المقاييسAV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H
Name of the Vulnerable Software and Affected Versions PHP versions prior to 7.0.9
Description The issue allows remote attackers to redirect an application's outbound HTTP traffic to an arbitrary proxy server via a crafted Proxy header in an HTTP request. This can be achieved by exploiting the presence of untrusted client data in the HTTP PROXY environment variable, which the application does not protect against. The issue affects applications that make a getenv('HTTP PROXY') call or have a CGI configuration of PHP.
Recommendations For PHP versions prior to 7.0.9, update to version 7.0.9 or later to resolve the issue. As a temporary workaround, consider restricting access to the HTTP PROXY environment variable to minimize the risk of exploitation. Avoid using the getenv('HTTP PROXY') call in applications until the issue is resolved.
قابلية الاستغلال
استغلال
إصلاح
التأثيرات
الباحثون
المورّدون
المنتجات المتأثرة
المعرّفات ذات الصلة
GHSA-M6CH-GG5F-WXX3
CESA-2016_1609
CESA-2016_1613
DLA-749-1
DSA-3631-1
OPENSUSE-SU-2024:11175-1
RHSA-2016:1609
RHSA-2016_1609
RHSA-2016:1610
RHSA-2016:1611
RHSA-2016:1612
RHSA-2016:1613
RHSA-2016_1613
SUSE-SU-2016:1842-1
SUSE-SU-2016:2941-1
SUSE-SU-2016_2941-1
USN-3045-1
وجدت خطأً في الوصف؟ لديك ما تضيفه؟ لا تتردد في مراسلتنا 👾