PT-2016-6642

CVE-2016-5688

·

تاريخ النشر

2016-06-05

·

تاريخ التحديث

2016-12-16

الوصف من

CVSS 3.1
8.1
عالية
المقاييسAV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H
Name of the Vulnerable Software and Affected Versions ImageMagick versions prior to 6.9.4-4 ImageMagick versions 7.x prior to 7.0.1-5
Description The issue concerns the WPG parser in ImageMagick. When a memory limit is set, it allows remote attackers to have an unspecified impact via certain vectors. These vectors are related to the SetImageExtent return-value check and can trigger a heap-based buffer overflow in the SetPixelIndex function or an invalid write operation in the ScaleCharToQuantum or SetPixelIndex functions.
Recommendations For ImageMagick versions prior to 6.9.4-4, update to version 6.9.4-4 or later. For ImageMagick versions 7.x prior to 7.0.1-5, update to version 7.0.1-5 or later.
قابلية الاستغلال
إصلاح
التأثيرات
الباحثون
المورّدون
المنتجات المتأثرة
المعرّفات ذات الصلة
ALT-PU-2016-1580
DLA-731-1
DSA-3652-1
OPENSUSE-SU-2016_1724-1
OPENSUSE-SU-2016_1748-1
OPENSUSE-SU-2016_1833-1
OPENSUSE-SU-2016_2073-1
SUSE-SU-2016:1782-1
SUSE-SU-2016:1783-1
SUSE-SU-2016:1784-1
USN-3131-1
وجدت خطأً في الوصف؟ لديك ما تضيفه؟ لا تتردد في مراسلتنا 👾