PT-2016-6822

CVE-2016-6316

·

تاريخ النشر

2016-08-25

·

تاريخ التحديث

2019-08-08

الوصف من

CVSS 3.1
6.1
متوسطة
المقاييسAV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
Name of the Vulnerable Software and Affected Versions Ruby on Rails versions 3.x before 3.2.22.3 Ruby on Rails versions 4.x before 4.2.7.1 Ruby on Rails versions 5.x before 5.0.0.1
Description A cross-site scripting (XSS) issue in Action View in Ruby on Rails might allow remote attackers to inject arbitrary web script or HTML via text declared as "HTML safe" and used as attribute values in tag handlers.
Recommendations For Ruby on Rails versions 3.x before 3.2.22.3, update to version 3.2.22.3 or later. For Ruby on Rails versions 4.x before 4.2.7.1, update to version 4.2.7.1 or later. For Ruby on Rails versions 5.x before 5.0.0.1, update to version 5.0.0.1 or later.
قابلية الاستغلال
استغلال
إصلاح
التأثيرات
الباحثون
المورّدون
المنتجات المتأثرة
المعرّفات ذات الصلة
GHSA-PC3M-V286-2JWJ
DLA-604-1
DSA-3651-1
RHSA-2016:1855
RHSA-2016:1856
RHSA-2016:1857
RHSA-2016:1858
SUSE-SU-2017:2716-1
وجدت خطأً في الوصف؟ لديك ما تضيفه؟ لا تتردد في مراسلتنا 👾