PT-2017-10700
CVE-2017-0899
·
تاريخ النشر
2017-08-31
·
تاريخ التحديث
2026-09-18
الوصف من
CVSS 3.1
9.8
حرجةالمقاييسAV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Name of the Vulnerable Software and Affected Versions
RubyGems versions 2.6.12 and earlier
Description
The issue allows maliciously crafted gem specifications that include terminal escape characters to execute terminal escape sequences when the gem specification is printed. This could potentially lead to unintended consequences.
Recommendations
For RubyGems versions 2.6.12 and earlier, update to version 2.6.13 or later to resolve the issue.
قابلية الاستغلال
استغلال
إصلاح
التأثيرات
الباحثون
المورّدون
المنتجات المتأثرة
وجدت خطأً في الوصف؟ لديك ما تضيفه؟ لا تتردد في مراسلتنا 👾