PT-2017-10905

CVE-2017-1000207

·

تاريخ النشر

2017-11-27

·

تاريخ التحديث

2019-10-03

الوصف من

CVSS 3.1
8.8
عالية
المقاييسAV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Name of the Vulnerable Software and Affected Versions Swagger-Parser versions <= 1.0.30 Swagger codegen versions <= 2.2.2
Description A vulnerability in Swagger-Parser's yaml parsing functionality results in arbitrary code being executed when a maliciously crafted yaml Open-API specification is parsed. This affects the 'generate' and 'validate' commands in swagger-codegen and can lead to arbitrary code being executed when these commands are used on a well-crafted yaml specification.
Recommendations For Swagger-Parser versions <= 1.0.30, update to a version greater than 1.0.30 to resolve the issue. For Swagger codegen versions <= 2.2.2, update to a version greater than 2.2.2 to resolve the issue. As a temporary workaround, consider restricting the use of the 'generate' and 'validate' commands in swagger-codegen until a patch is available.
قابلية الاستغلال
إصلاح
التأثيرات
الباحثون
المورّدون
المنتجات المتأثرة
تصنيف نقاط الضعف
المعرّفات ذات الصلة
GHSA-Q7PF-QR96-2VQ5
GHSA-VGVF-9JH3-FG75
وجدت خطأً في الوصف؟ لديك ما تضيفه؟ لا تتردد في مراسلتنا 👾