PT-2017-10939

CVE-2017-1000246

·

تاريخ النشر

2017-11-17

·

تاريخ التحديث

2020-07-29

الوصف من

CVSS 4.0
6.3
متوسطة
المقاييسAV:N/AC:H/AT:N/PR:N/UI:N/VC:L/VI:N/VA:N/SC:N/SI:N/SA:N
Name of the Vulnerable Software and Affected Versions pysaml2 versions 4.5.0 and earlier
Description The issue results from the reuse of the initialization vector across encryptions in the IDP server, leading to weak encryption of data.
Recommendations For versions 4.5.0 and earlier, update to a version later than 4.5.0 to resolve the issue. At the moment, there is no information about a newer version that contains a fix for this vulnerability.
التأثيرات
المورّدون
المنتجات المتأثرة
تصنيف نقاط الضعف
المعرّفات ذات الصلة
GHSA-CQ94-QF6Q-MF2H
PYSEC-2017-26
SUSE-RU-2020:2072-1
SUSE-SU-2020:1901-1
وجدت خطأً في الوصف؟ لديك ما تضيفه؟ لا تتردد في مراسلتنا 👾