PT-2017-13213

CVE-2017-14033

·

تاريخ النشر

2017-09-16

·

تاريخ التحديث

2026-09-18

الوصف من

CVSS 3.1
7.5
عالية
المقاييسAV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Name of the Vulnerable Software and Affected Versions Ruby versions prior to 2.2.8 Ruby versions 2.3.x prior to 2.3.5 Ruby versions 2.4.x through 2.4.1
Description The issue allows attackers to cause a denial of service, resulting in an interpreter crash, via a crafted string. This is due to a problem in the decode method of the OpenSSL::ASN1 module in Ruby.
Recommendations For Ruby versions prior to 2.2.8, update to version 2.2.8 or later. For Ruby versions 2.3.x prior to 2.3.5, update to version 2.3.5 or later. For Ruby versions 2.4.x through 2.4.1, update to a version later than 2.4.1. As a temporary workaround, consider disabling the decode method in the OpenSSL::ASN1 module until a patch is available.
قابلية الاستغلال
استغلال
إصلاح
التأثيرات
الباحثون
المورّدون
المنتجات المتأثرة
المعرّفات ذات الصلة
GHSA-V6RP-3R3V-HF4P
ALT-PU-2017-2216
CESA-2018_0378
CLEANSTART-2026-PG57442
DLA-1114-1
DLA-1421-1
DSA-4031-1
MGASA-2017-0371
RHSA-2018:0378
RHSA-2018_0378
RHSA-2018:0583
RHSA-2018:0585
SUSE-SU-2020:1570-1
SUSE-SU-2020_1570-1
USN-3439-1
USN-3528-1
وجدت خطأً في الوصف؟ لديك ما تضيفه؟ لا تتردد في مراسلتنا 👾