PT-2017-13488
CVE-2017-14495
·
تاريخ النشر
2017-10-02
·
تاريخ التحديث
2026-09-18
الوصف من
CVSS 3.1
7.5
عاليةالمقاييسAV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Name of the Vulnerable Software and Affected Versions
dnsmasq versions prior to 2.78
Description
The issue is related to a memory leak that can be triggered when specific options such as
--add-mac, --add-cpe-id, or --add-subnet are used. This allows remote attackers to cause a denial of service by consuming memory through vectors involving DNS response creation.Recommendations
For dnsmasq versions prior to 2.78, update to version 2.78 or later to resolve the issue. As a temporary workaround, consider avoiding the use of the
--add-mac, --add-cpe-id, and --add-subnet options until the update is applied.قابلية الاستغلال
استغلال
إصلاح
التأثيرات
الباحثون
المورّدون
المنتجات المتأثرة
وجدت خطأً في الوصف؟ لديك ما تضيفه؟ لا تتردد في مراسلتنا 👾