PT-2017-14498

CVE-2017-16618

·

تاريخ النشر

2017-11-08

·

تاريخ التحديث

2019-10-03

الوصف من

CVSS 3.1
9.8
حرجة
المقاييسAV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Name of the Vulnerable Software and Affected Versions OwlMixin versions prior to 2.0.0a12
Description The issue exists in the YAML loading functionality of util.py, where a "Load YAML" string or file can execute arbitrary Python commands. This is due to the use of load instead of safe load, allowing an attacker to insert Python into loaded YAML and trigger command execution.
Recommendations For versions prior to 2.0.0a12, update to version 2.0.0a12 or later to resolve the issue. As a temporary workaround, consider disabling the load yaml and load yamlf functions in util.py until a patch is available. Restrict access to YAML loading functionality to minimize the risk of exploitation. Avoid using the load function for YAML loading; instead, use the safe load function to prevent arbitrary command execution.
قابلية الاستغلال
استغلال
إصلاح
التأثيرات
الباحثون
المورّدون
المنتجات المتأثرة
تصنيف نقاط الضعف
المعرّفات ذات الصلة
GHSA-CCMQ-QVCP-5MRM
PYSEC-2017-22
وجدت خطأً في الوصف؟ لديك ما تضيفه؟ لا تتردد في مراسلتنا 👾