PT-2017-15038

CVE-2017-17840

·

تاريخ النشر

2017-12-22

·

تاريخ التحديث

2018-12-21

الوصف من

CVSS 3.1
7.8
عالية
المقاييسAV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
Name of the Vulnerable Software and Affected Versions Open-iSCSI versions prior to 2.0.876
Description A local attacker can cause the iscsiuio server to abort or potentially execute code by sending messages with incorrect lengths. This is due to a lack of checking, which can lead to buffer overflows. The process iscsid broadcast function in iscsiuio/src/unix/iscsid ipc.c does not validate the payload length before a write operation.
Recommendations For Open-iSCSI versions prior to 2.0.876, update to version 2.0.876 or later to resolve the issue. As a temporary workaround, consider restricting access to the iscsiuio server to minimize the risk of exploitation.
قابلية الاستغلال
إصلاح
التأثيرات
المورّدون
المنتجات المتأثرة
المعرّفات ذات الصلة
ALT-PU-2018-2938
وجدت خطأً في الوصف؟ لديك ما تضيفه؟ لا تتردد في مراسلتنا 👾