PT-2017-15551

CVE-2017-2809

·

تاريخ النشر

2017-09-14

·

تاريخ التحديث

2022-04-19

الوصف من

CVSS 4.0
8.5
عالية
المقاييسAV:L/AC:L/AT:N/PR:N/UI:P/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N
Name of the Vulnerable Software and Affected Versions ansible-vault versions prior to 1.0.5
Description The issue concerns the yaml loading functionality, where a specially crafted vault can execute arbitrary python commands, resulting in command execution. An attacker can insert python into the vault to trigger this vulnerability.
Recommendations For versions prior to 1.0.5, update to version 1.0.5 or later to resolve the issue.
قابلية الاستغلال
استغلال
إصلاح
التأثيرات
الباحثون
المورّدون
المنتجات المتأثرة
المعرّفات ذات الصلة
GHSA-C2W9-48QC-QPJ4
PYSEC-2017-5
وجدت خطأً في الوصف؟ لديك ما تضيفه؟ لا تتردد في مراسلتنا 👾