PT-2017-16589
CVE-2017-5581
·
تاريخ النشر
2017-01-13
·
تاريخ التحديث
2018-01-05
الوصف من
CVSS 3.1
9.8
حرجةالمقاييسAV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Name of the Vulnerable Software and Affected Versions
TigerVNC versions prior to 1.7.1
Description
The issue is related to a buffer overflow in the ModifiablePixelBuffer::fillRect function. This allows remote servers to execute arbitrary code via an RRE message with a subrectangle outside framebuffer boundaries.
Recommendations
For versions prior to 1.7.1, update to version 1.7.1 or later to resolve the issue.
وجدت خطأً في الوصف؟ لديك ما تضيفه؟ لا تتردد في مراسلتنا 👾