PT-2017-19193

CVE-2017-9799

·

تاريخ النشر

2017-08-09

·

تاريخ التحديث

2019-10-03

الوصف من

CVSS 3.1
8.8
عالية
المقاييسAV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Name of the Vulnerable Software and Affected Versions Apache Storm versions 1.0.0 through 1.0.3 Apache Storm versions 1.1.0 through 1.1.0
Description A security issue was discovered in Apache Storm where, under certain situations and configurations, the owner of a topology could potentially trick the supervisor into launching a worker as a different, non-root user. This could lead to the compromise of secure credentials of the other user.
Recommendations For Apache Storm versions 1.0.0 through 1.0.3, update to version 1.0.4 or later. For Apache Storm versions 1.1.0 through 1.1.0, update to version 1.1.1 or later.
قابلية الاستغلال
إصلاح
المورّدون
المنتجات المتأثرة
المعرّفات ذات الصلة
GHSA-X825-RJWW-2245
SUSE-SU-2017:3000-1
وجدت خطأً في الوصف؟ لديك ما تضيفه؟ لا تتردد في مراسلتنا 👾