PT-2017-2398
CVE-2016-10160
·
تاريخ النشر
2017-01-24
·
تاريخ التحديث
2022-07-20
الوصف من
CVSS 3.1
9.8
حرجةالمقاييسAV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Name of the Vulnerable Software and Affected Versions
PHP versions prior to 5.6.30
PHP versions 7.0.x prior to 7.0.15
Description
The issue is related to an off-by-one error in the
phar parse pharfile function. This error can be exploited by remote attackers to cause a denial of service (memory corruption) or possibly execute arbitrary code. The exploitation is done via a crafted PHAR archive with an alias mismatch.Recommendations
For PHP versions prior to 5.6.30, update to version 5.6.30 or later.
For PHP versions 7.0.x prior to 7.0.15, update to version 7.0.15 or later.
وجدت خطأً في الوصف؟ لديك ما تضيفه؟ لا تتردد في مراسلتنا 👾