PT-2017-2403

CVE-2016-9317

·

تاريخ النشر

2017-01-26

·

تاريخ التحديث

2024-06-15

الوصف من

CVSS 2.0
7.1
عالية
المقاييسAV:N/AC:M/Au:N/C:N/I:N/A:C
Name of the Vulnerable Software and Affected Versions GD Graphics Library versions prior to 2.2.4
Description The issue is related to insufficient input validation in the gdImageCreate function, which can be exploited by remote attackers to cause a denial of service, resulting in a system hang. This can be achieved by using an oversized image.
Recommendations For versions prior to 2.2.4, update to version 2.2.4 or later to resolve the issue. As a temporary workaround, consider validating and limiting the size of input images to prevent oversized images from being processed by the gdImageCreate function.
قابلية الاستغلال
إصلاح
التأثيرات
الباحثون
المورّدون
المنتجات المتأثرة
تصنيف نقاط الضعف
المعرّفات ذات الصلة
DLA-804-1
DSA-3777-1
MGASA-2017-0055
MGASA-2017-0086
OPENSUSE-SU-2024:10777-1
SUSE-SU-2017:0459-1
SUSE-SU-2017:0468-1
USN-3213-1
وجدت خطأً في الوصف؟ لديك ما تضيفه؟ لا تتردد في مراسلتنا 👾