PT-2017-2768
CVE-2017-12932
·
تاريخ النشر
2017-01-09
·
تاريخ التحديث
2018-05-04
الوصف من
CVSS 3.1
9.8
حرجةالمقاييسAV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Name of the Vulnerable Software and Affected Versions
PHP versions 7.0.x through 7.0.22
PHP versions 7.1.x through 7.1.8
Description
The issue is related to a heap use after free while unserializing untrusted data, due to improper use of the hash API for key deletion in a situation with an invalid array size. Exploitation of this issue can have an unspecified impact on the integrity of PHP.
Recommendations
For PHP versions 7.0.x through 7.0.22, update to a version later than 7.0.22 to resolve the issue.
For PHP versions 7.1.x through 7.1.8, update to a version later than 7.1.8 to resolve the issue.
وجدت خطأً في الوصف؟ لديك ما تضيفه؟ لا تتردد في مراسلتنا 👾