PT-2017-2795

CVE-2017-9805

·

تاريخ النشر

2017-09-05

·

تاريخ التحديث

2026-03-10

الوصف من

CVSS 2.0
7.6
عالية
المقاييسAV:N/AC:H/Au:N/C:C/I:C/A:C
Name of the Vulnerable Software and Affected Versions Apache Struts versions 2.1.1 through 2.3.x before 2.3.34 Apache Struts versions 2.5.x before 2.5.13
Description The issue is related to the REST Plugin in Apache Struts, which uses an XStreamHandler with an instance of XStream for deserialization without any type filtering. This can lead to Remote Code Execution when deserializing XML payloads. The vulnerability exists due to the lack of filtering during the deserialization of XML requests, allowing remote attackers to execute arbitrary code.
Recommendations For Apache Struts versions 2.1.1 through 2.3.x before 2.3.34, upgrade to version 2.3.34 or later. For Apache Struts versions 2.5.x before 2.5.13, upgrade to version 2.5.13 or later. As a temporary workaround, consider disabling the XStreamHandler until a patch is available. Restrict access to the REST Plugin to minimize the risk of exploitation. Avoid using the XStream library for deserialization until the issue is resolved.
قابلية الاستغلال
استغلال
إصلاح
التأثيرات
الباحثون
المورّدون
المنتجات المتأثرة
المعرّفات ذات الصلة
GHSA-29RM-6752-GVWV
GHSA-8FX9-5HX8-CRHM
GHSA-8MR5-H28G-36QX
GHSA-9GP7-JVM2-R4MX
GHSA-GG9M-FJ3V-R58C
GHSA-VWXJ-6M5M-RRVH
GHSA-X5X7-3V85-WPC4
APACHESTRUTSCVE20179805CHECK
وجدت خطأً في الوصف؟ لديك ما تضيفه؟ لا تتردد في مراسلتنا 👾