PT-2017-4185

CVE-2016-10158

·

تاريخ النشر

2017-01-24

·

تاريخ التحديث

2018-05-04

الوصف من

CVSS 2.0
7.8
عالية
المقاييسAV:N/AC:L/Au:N/C:N/I:N/A:C
Name of the Vulnerable Software and Affected Versions PHP versions prior to 5.6.30 PHP versions 7.0.x prior to 7.0.15 PHP versions 7.1.x prior to 7.1.1
Description The issue is related to errors in number processing in the exif convert any to int function. This can be exploited by remote attackers to cause a denial of service (application crash) via crafted EXIF data. The exploitation is possible due to an attempt to divide the minimum representable negative integer by -1.
Recommendations For PHP versions prior to 5.6.30, update to version 5.6.30 or later. For PHP versions 7.0.x prior to 7.0.15, update to version 7.0.15 or later. For PHP versions 7.1.x prior to 7.1.1, update to version 7.1.1 or later.
قابلية الاستغلال
إصلاح
التأثيرات
الباحثون
المورّدون
المنتجات المتأثرة
تصنيف نقاط الضعف
المعرّفات ذات الصلة
ALT-PU-2017-1114
DLA-818-1
DSA-3783-1
MGASA-2017-0040
OPENSUSE-SU-2017_0588-1
RHSA-2018:1296
SUSE-SU-2017:0534-1
SUSE-SU-2017_0534-1
SUSE-SU-2017:0556-1
SUSE-SU-2017_0556-1
SUSE-SU-2017:0568-1
SUSE-SU-2017_0568-1
USN-3196-1
USN-3211-1
USN-3211-2
وجدت خطأً في الوصف؟ لديك ما تضيفه؟ لا تتردد في مراسلتنا 👾