PT-2017-4211
CVE-2017-18359
·
تاريخ النشر
2017-02-09
·
تاريخ التحديث
2022-07-06
الوصف من
CVSS 2.0
7.8
عاليةالمقاييسAV:N/AC:L/Au:N/C:N/I:N/A:C
Name of the Vulnerable Software and Affected Versions
PostGIS versions 2.x through 2.3.2
Description
The issue is related to the ST AsX3D function in PostGIS, which is used with PostgreSQL. It allows remote attackers to cause a denial of service via crafted input, as demonstrated by an abnormal server termination when handling empty geometries. The problem is associated with insufficient input validation in the ST AsX3D function of the PostGIS module for geographic object processing in PostgreSQL.
Recommendations
For PostGIS versions 2.x through 2.3.2, update to version 2.3.3 or later to resolve the issue.
As a temporary workaround, consider restricting the use of the ST AsX3D function until a patch is available.
قابلية الاستغلال
استغلال
إصلاح
التأثيرات
الباحثون
المورّدون
المنتجات المتأثرة
وجدت خطأً في الوصف؟ لديك ما تضيفه؟ لا تتردد في مراسلتنا 👾