PT-2017-5748
CVE-2013-7377
·
تاريخ النشر
2017-10-23
·
تاريخ التحديث
2017-11-28
الوصف من
CVSS 3.1
8.1
عاليةالمقاييسAV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H
Name of the Vulnerable Software and Affected Versions:
codem-transcode module versions prior to 0.5.0
Description:
The issue allows remote attackers to execute arbitrary commands via a POST request to "/probe" when ffprobe is enabled. This is possible because HTTP POST requests to "/probe" are passed to the ffprobe binary on the server, allowing a malformed source file name to be sent, resulting in arbitrary command execution. The ffprobe functionality is not enabled by default, and exploitation opportunities are limited in a standard configuration because the server binds to the local interface by default.
Recommendations:
For versions prior to 0.5.0, update to version 0.5.0 or later, available via npm, especially if the ffprobe functionality is enabled. As a temporary workaround, consider disabling the ffprobe functionality until the update is applied. Restrict access to the "/probe" endpoint to minimize the risk of exploitation.
وجدت خطأً في الوصف؟ لديك ما تضيفه؟ لا تتردد في مراسلتنا 👾