PT-2017-6566
CVE-2015-2310
·
تاريخ النشر
2017-08-09
·
تاريخ التحديث
2019-12-11
الوصف من
CVSS 3.1
9.1
حرجةالمقاييسAV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:H
Name of the Vulnerable Software and Affected Versions
Sandstorm Cap'n Proto versions prior to 0.4.1.1
Sandstorm Cap'n Proto versions 0.5.x prior to 0.5.1.1
Description
The issue is related to an integer overflow in the layout.c++ file, which can be exploited by remote peers via a crafted message. This could lead to a denial of service or potentially allow access to sensitive information from memory, due to inadequate pointer validation.
Recommendations
For Sandstorm Cap'n Proto versions prior to 0.4.1.1, update to version 0.4.1.1 or later.
For Sandstorm Cap'n Proto versions 0.5.x prior to 0.5.1.1, update to version 0.5.1.1 or later.
وجدت خطأً في الوصف؟ لديك ما تضيفه؟ لا تتردد في مراسلتنا 👾