PT-2017-8715

CVE-2016-5394

·

تاريخ النشر

2017-07-19

·

تاريخ التحديث

2022-05-13

الوصف من

CVSS 3.1
6.1
متوسطة
المقاييسAV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
Name of the Vulnerable Software and Affected Versions Apache Sling versions prior to 1.0.12
Description The issue arises from the XSS Protection API module, where the encoding performed by the XSSAPI.encodeForJSString() method is not restrictive enough. This allows script tags to pass through unencoded for certain input patterns, potentially leading to XSS vulnerabilities.
Recommendations For versions prior to 1.0.12, update to version 1.0.12 or later to resolve the issue. As a temporary workaround, consider restricting the use of the XSSAPI.encodeForJSString() method until a patch is applied.
قابلية الاستغلال
استغلال
إصلاح
التأثيرات
المورّدون
المنتجات المتأثرة
المعرّفات ذات الصلة
GHSA-XWF4-88XR-HX2J
وجدت خطأً في الوصف؟ لديك ما تضيفه؟ لا تتردد في مراسلتنا 👾