PT-2017-9772

CVE-2016-8737

·

تاريخ النشر

2017-09-13

·

تاريخ التحديث

2022-05-17

الوصف من

CVSS 3.1
8.8
عالية
المقاييسAV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Name of the Vulnerable Software and Affected Versions Apache Brooklyn versions prior to 0.10.0
Description The issue allows a malicious web site to produce a link that, if clicked while a user is logged in, could cause the server to execute the attacker's commands as the user. This is due to the REST server being vulnerable to cross-site request forgery (CSRF). A proof-of-concept exploit using this issue is known to exist.
Recommendations For versions prior to 0.10.0, update to version 0.10.0 or later to resolve the issue. As a temporary workaround, consider implementing CSRF protection mechanisms, such as token-based validation, to minimize the risk of exploitation. Restrict access to sensitive operations within the REST server to minimize potential damage until the update can be applied.
قابلية الاستغلال
استغلال
إصلاح
التأثيرات
الباحثون
المورّدون
المنتجات المتأثرة
تصنيف نقاط الضعف
المعرّفات ذات الصلة
GHSA-G2HF-G7FH-VG92
وجدت خطأً في الوصف؟ لديك ما تضيفه؟ لا تتردد في مراسلتنا 👾