PT-2018-1006
CVE-2018-5440
·
تاريخ النشر
2018-02-01
·
تاريخ التحديث
2020-09-18
الوصف من
CVSS 2.0
10
حرجةالمقاييسAV:N/AC:L/Au:N/C:C/I:C/A:C
Name of the Vulnerable Software and Affected Versions
3S-Smart CODESYS Web Server version 2.3
3S-Smart CODESYS Web Server versions prior to V1.1.9.19
Description
A Stack-based Buffer Overflow issue was discovered in the 3S-Smart CODESYS Web Server. This issue can be exploited by a crafted request, potentially causing a buffer overflow, which could lead to the execution of arbitrary code on the web server or result in a denial-of-service condition due to a crash in the web server.
Recommendations
For version 2.3, update to a version newer than V1.1.9.19 to resolve the issue.
For versions prior to V1.1.9.19, update to version V1.1.9.19 or newer to resolve the issue.
As a temporary workaround, consider restricting access to the web server to minimize the risk of exploitation.
وجدت خطأً في الوصف؟ لديك ما تضيفه؟ لا تتردد في مراسلتنا 👾