PT-2018-10695

CVE-2018-11596

·

تاريخ النشر

2018-05-31

·

تاريخ التحديث

2018-06-08

الوصف من

CVSS 3.1
5.5
متوسطة
المقاييسAV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H
Name of the Vulnerable Software and Affected Versions Espruino versions prior to 1.99
Description The issue allows attackers to cause a denial of service, resulting in an application crash, by providing a user-crafted input file. This is due to a Buffer Overflow that occurs during syntax parsing. The problem arises from a check for '0' being made for the wrong array element in jsvar.c.
Recommendations For versions prior to 1.99, update to version 1.99 or later to resolve the issue.
قابلية الاستغلال
إصلاح
التأثيرات
الباحثون
المورّدون
المنتجات المتأثرة
المعرّفات ذات الصلة
وجدت خطأً في الوصف؟ لديك ما تضيفه؟ لا تتردد في مراسلتنا 👾