PT-2018-13185

CVE-2018-15758

·

تاريخ النشر

2018-10-18

·

تاريخ التحديث

2019-10-03

الوصف من

CVSS 3.1
9.6
حرجة
المقاييسAV:N/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:N
Name of the Vulnerable Software and Affected Versions Spring Security OAuth versions 2.0 prior to 2.0.16 Spring Security OAuth versions 2.1 prior to 2.1.3 Spring Security OAuth versions 2.2 prior to 2.2.3 Spring Security OAuth versions 2.3 prior to 2.3.4
Description The issue allows a malicious user to craft a request to the approval endpoint, potentially leading to a privilege escalation on subsequent approval. This can occur when the application is configured to use a custom approval endpoint that declares AuthorizationRequest as a controller method argument, and the application acts in the role of an Authorization Server.
Recommendations For Spring Security OAuth versions 2.0 prior to 2.0.16, update to version 2.0.16 or later. For Spring Security OAuth versions 2.1 prior to 2.1.3, update to version 2.1.3 or later. For Spring Security OAuth versions 2.2 prior to 2.2.3, update to version 2.2.3 or later. For Spring Security OAuth versions 2.3 prior to 2.3.4, update to version 2.3.4 or later. As a temporary workaround, consider disabling the custom approval endpoint that declares AuthorizationRequest as a controller method argument until a patch is available.
قابلية الاستغلال
إصلاح
التأثيرات
الباحثون
المورّدون
المنتجات المتأثرة
تصنيف نقاط الضعف
المعرّفات ذات الصلة
GHSA-H8W4-QV99-F7VJ
وجدت خطأً في الوصف؟ لديك ما تضيفه؟ لا تتردد في مراسلتنا 👾