PT-2018-13711

CVE-2018-16733

·

تاريخ النشر

2018-09-08

·

تاريخ التحديث

2025-08-08

الوصف من

CVSS 3.1
7.5
عالية
المقاييسAV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N
Name of the Vulnerable Software and Affected Versions Go Ethereum versions prior to 1.8.14
Description The issue arises from improper input validation in the TraceChain function within the eth/api tracer.go file. Specifically, it does not verify that the end block is after the start block. This affects the github.com/ethereum/go-ethereum/eth package.
Recommendations For versions prior to 1.8.14, update to version 1.8.14 or later to resolve the issue. As a temporary workaround, consider validating block ranges manually to ensure the end block is after the start block until a patch is applied. Restrict access to the TraceChain function in the eth/api tracer.go file to minimize the risk of exploitation.
قابلية الاستغلال
إصلاح
التأثيرات
المورّدون
المنتجات المتأثرة
تصنيف نقاط الضعف
المعرّفات ذات الصلة
GHSA-QR2J-WRHX-4829
GO-2022-0871
OPENSUSE-SU-2025:15424-1
وجدت خطأً في الوصف؟ لديك ما تضيفه؟ لا تتردد في مراسلتنا 👾