PT-2018-16185

CVE-2018-3767

·

تاريخ النشر

2018-07-05

·

تاريخ التحديث

2019-10-09

الوصف من

CVSS 3.1
9.1
حرجة
المقاييسAV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:H
Name of the Vulnerable Software and Affected Versions memjs versions <= 1.1.0 memjs versions prior to 1.2.2
Description The issue results in Denial of Service (DoS) and uninitialized memory usage due to the allocation and storage of buffers on typed input. The package fails to sanitize the value option passed to the Buffer constructor, allowing attackers to pass large values that exhaust system resources.
Recommendations For memjs versions <= 1.1.0, upgrade to version 1.2.2 or later. For memjs versions prior to 1.2.2, upgrade to version 1.2.2 or later.
قابلية الاستغلال
استغلال
إصلاح
التأثيرات
الباحثون
المورّدون
المنتجات المتأثرة
تصنيف نقاط الضعف
المعرّفات ذات الصلة
GHSA-CX8M-8XMX-Q8V3
وجدت خطأً في الوصف؟ لديك ما تضيفه؟ لا تتردد في مراسلتنا 👾