PT-2018-16190

CVE-2018-3772

·

تاريخ النشر

2018-07-30

·

تاريخ التحديث

2019-10-09

الوصف من

CVSS 3.1
9.8
حرجة
المقاييسAV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Name of the Vulnerable Software and Affected Versions whereis versions prior to 0.4.1
Description The issue arises from concatenating unsanitized user input in the whereis npm module, allowing an attacker to execute arbitrary commands. It is recommended to use the which npm module instead, as whereis is deprecated.
Recommendations Update to version 0.4.1 or later. As a temporary workaround, consider avoiding the use of the whereis module with untrusted user input until a patch is applied or the module is updated.
قابلية الاستغلال
استغلال
إصلاح
التأثيرات
الباحثون
المورّدون
المنتجات المتأثرة
المعرّفات ذات الصلة
GHSA-WJR4-2JGW-HMV8
وجدت خطأً في الوصف؟ لديك ما تضيفه؟ لا تتردد في مراسلتنا 👾