PT-2018-18227

CVE-2018-7711

·

تاريخ النشر

2018-03-05

·

تاريخ التحديث

2022-05-14

الوصف من

CVSS 3.1
8.1
عالية
المقاييسAV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H
Name of the Vulnerable Software and Affected Versions: SimpleSAMLphp versions prior to 1.15.4
Description: The issue arises from an incorrect check of return values in the signature validation utilities within the saml2 library of SimpleSAMLphp. This allows an attacker to force an error during validation, resulting in invalid signatures being accepted as valid. The problem stems from a dependency on PHP functionality that interprets a -1 error code as a true boolean value.
Recommendations: For versions prior to 1.15.4, update to version 1.15.4 or later to resolve the issue.
قابلية الاستغلال
استغلال
إصلاح
التأثيرات
الباحثون
المورّدون
المنتجات المتأثرة
المعرّفات ذات الصلة
GHSA-G888-G2PP-82HF
DLA-1314-1
وجدت خطأً في الوصف؟ لديك ما تضيفه؟ لا تتردد في مراسلتنا 👾