PT-2018-2693
CVE-2018-18584
·
تاريخ النشر
2018-10-22
·
تاريخ التحديث
2026-09-30
الوصف من
CVSS 2.0
7.5
عاليةالمقاييسAV:N/AC:L/Au:N/C:P/I:P/A:P
Name of the Vulnerable Software and Affected Versions
libmspack versions prior to 0.8alpha
cabextract versions prior to 1.8
Description
The issue is related to an out-of-bounds write in the CAB block input buffer, which can be exploited by a remote attacker to execute arbitrary code or cause a denial of service. The problem arises because the buffer is one byte too small for the maximal Quantum block.
Recommendations
For libmspack versions prior to 0.8alpha, update to version 0.8alpha or later to resolve the issue.
For cabextract versions prior to 1.8, update to version 1.8 or later to resolve the issue.
وجدت خطأً في الوصف؟ لديك ما تضيفه؟ لا تتردد في مراسلتنا 👾