PT-2018-2699

CVE-2019-9924

·

تاريخ النشر

2018-11-14

·

تاريخ التحديث

2022-04-05

الوصف من

CVSS 3.1
7.8
عالية
المقاييسAV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
Name of the Vulnerable Software and Affected Versions Bash versions prior to 4.4-beta2
Description The issue is related to the restricted command interpreter rbash in Bash, which is associated with insufficient checking of the BASH CMDS array values. This could allow an attacker to execute arbitrary commands. The problem arises because rbash does not prevent the shell user from modifying BASH CMDS, thus enabling the user to execute any command with the permissions of the shell.
Recommendations For versions prior to 4.4-beta2, update to version 4.4-beta2 or later to resolve the issue. As a temporary workaround, consider restricting access to the BASH CMDS array to minimize the risk of exploitation.
قابلية الاستغلال
إصلاح
التأثيرات
الباحثون
المورّدون
المنتجات المتأثرة
المعرّفات ذات الصلة
ALT-PU-2018-2880
CESA-2020_1113
DLA-1726-1
MGASA-2019-0163
OPENSUSE-SU-2019_1178-1
RHSA-2020:1113
RHSA-2020_1113
RHSA-2020:3474
RHSA-2020:3592
RHSA-2020:3803
SUSE-SU-2019:0838-1
SUSE-SU-2019_0838-1
SUSE-SU-2019:0838-2
SUSE-SU-2019_0838-2
SUSE-SU-2019:0898-1
SUSE-SU-2019_0898-1
USN-4058-1
USN-4058-2
وجدت خطأً في الوصف؟ لديك ما تضيفه؟ لا تتردد في مراسلتنا 👾