PT-2018-2736
CVE-2018-10858
·
تاريخ النشر
2018-08-14
·
تاريخ التحديث
2024-06-15
الوصف من
CVSS 3.1
8.8
عاليةالمقاييسAV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
Name of the Vulnerable Software and Affected Versions
Samba versions prior to 4.6.16
Samba versions prior to 4.7.9
Samba versions prior to 4.8.4
Description
The issue is related to a heap-buffer overflow that occurs when Samba clients process extra long filenames in a directory listing. This can be exploited by a malicious Samba server to cause arbitrary code execution on a Samba client. The problem arises due to insufficient input validation in libsmbclient, allowing attackers to overwrite client heap memory.
Recommendations
For Samba versions prior to 4.6.16, update to version 4.6.16 or later.
For Samba versions prior to 4.7.9, update to version 4.7.9 or later.
For Samba versions prior to 4.8.4, update to version 4.8.4 or later.
قابلية الاستغلال
استغلال
إصلاح
التأثيرات
الباحثون
المورّدون
المنتجات المتأثرة
وجدت خطأً في الوصف؟ لديك ما تضيفه؟ لا تتردد في مراسلتنا 👾